Back to overview
Downtime
Main website unavailable
Jun 17 at 10:21pm BST
Affected services
scrcreate.app
Resolved
Jun 17 at 10:31pm BST
This issue has been resolved.
Affected services
Updated
Jun 17 at 10:27pm BST
We have identified the issue and implemented a fix, we are currently monitoring the results to see if other issues arise.
Affected services
Created
Jun 17 at 10:21pm BST
There is an issue going on with a looped redirect which makes it unable to visit the website.
Affected services